At some point in time with the newer versions of PHP, a lot of you would see this warning spit out by your PHP installation...